package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^(?:\s*{{.*?}}|\s*\[\[.*?]])*\n?`)
var str = `{{Ver desambig}}
{{Mais notas||ci|data=janeiro de 2013}}
{{Info/Taxonomia}}
[[Ficheiro:Pêra amarela.JPG|thumbnail|upright]]
A {{AO-pAO|pera|pêra}} é o fruto comestÃvel da pereira, uma [[árvore]] do.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}