import Foundation
let pattern = #"(?s)^(?:\s*{{.*?}}|\s*\[\[.*?]])*\n?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{{Ver desambig}}
{{Mais notas||ci|data=janeiro de 2013}}
{{Info/Taxonomia}}
[[Ficheiro:Pêra amarela.JPG|thumbnail|upright]]
A {{AO-pAO|pera|pêra}} é o fruto comestÃvel da pereira, uma [[árvore]] do.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)