import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^(?:\\s*\\{\\{.*?\\}\\}|\\s*\\[\\[.*?]])*\\n?";
final String string = "{{Ver desambig}}\n"
+ "{{Mais notas||ci|data=janeiro de 2013}}\n"
+ "{{Info/Taxonomia}}\n"
+ "[[Ficheiro:Pêra amarela.JPG|thumbnail|upright]]\n"
+ "A {{AO-pAO|pera|pêra}} é o fruto comestÃvel da pereira, uma [[árvore]] do.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}