using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-?\d+)x\^?(\d+)?";
string input = @"ax^3+bx^2+cx+d=0"" for example "" 2x^3+4x^2-6x+1=0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}