$re = '/(-?\d+)x\^?(\d+)?/';
$str = 'ax^3+bx^2+cx+d=0" for example " 2x^3+4x^2-6x+1=0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);