package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?\d+)x\^?(\d+)?`)
var str = `ax^3+bx^2+cx+d=0" for example " 2x^3+4x^2-6x+1=0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}