const regex = /(-?\d+)x\^?(\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-?\\d+)x\\^?(\\d+)?', 'g')
const str = `ax^3+bx^2+cx+d=0" for example " 2x^3+4x^2-6x+1=0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}