import Foundation
let pattern = #"(-?\d+)x\^?(\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ax^3+bx^2+cx+d=0" for example " 2x^3+4x^2-6x+1=0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)