// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(-?\d+)x\^?(\d+)?").unwrap();
let string = "ax^3+bx^2+cx+d=0\" for example \" 2x^3+4x^2-6x+1=0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}