# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-\d+x\d+(\.\w+)$/\1/;t' <<< "http://website.dev/2014/05/my-file-name-here-710x557.png"