$re = '/-\d+x\d+(\.\w+)$/';
$str = 'http://website.dev/2014/05/my-file-name-here-710x557.png';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;