using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-\d+x\d+(\.\w+)$";
string substitution = @"\1";
string input = @"http://website.dev/2014/05/my-file-name-here-710x557.png";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}