re = /-\d+x\d+(\.\w+)$/
str = 'http://website.dev/2014/05/my-file-name-here-710x557.png'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result