#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-\d+x\d+(\.\w+)$"
Local $sString = "http://website.dev/2014/05/my-file-name-here-710x557.png"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)