const regex = /-\d+x\d+(\.\w+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d+x\\d+(\\.\\w+)$', '')
const str = `http://website.dev/2014/05/my-file-name-here-710x557.png`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);