#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$"
Local $sString = "exactly16chAract"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)