using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$";
string substitution = @"";
string input = @"exactly16chAract";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}