re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$/
str = 'exactly16chAract'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result