use strict;
my $str = 'exactly16chAract';
my $regex = qr/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";