$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$/';
$str = 'exactly16chAract';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;