const regex = /^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(\w|\-){16}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)(\\w|\\-){16}$', '')
const str = `exactly16chAract`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);