#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9.]+)\s\-"
Local $sString = "1 - Primeira Clausura." & @CRLF & _
"1.1 - Primeiro paragrafo." & @CRLF & _
"1.2 - Segundo Paragrafo" & @CRLF & _
"...ddd" & @CRLF & _
"" & @CRLF & _
"2 - Segunda Clausura." & @CRLF & _
"2.1 - Primeiro paragrafo da segunda clausura." & @CRLF & _
"2.2 - Segundo paragrafo da segunda clausura." & @CRLF & _
"..." & @CRLF & _
"" & @CRLF & _
"3 - Terceira Clausura." & @CRLF & _
"3.1 - Terceiro paragrafo da Terceira clausura." & @CRLF & _
"3.2 - STerceiro paragrafo da Terceira clausura." & @CRLF & _
"..." & @CRLF & _
"/([0-9.]+)s-/g"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")