$re = '/([0-9.]+)\s\-/';
$str = '1 - Primeira Clausura.
1.1 - Primeiro paragrafo.
1.2 - Segundo Paragrafo
...ddd
2 - Segunda Clausura.
2.1 - Primeiro paragrafo da segunda clausura.
2.2 - Segundo paragrafo da segunda clausura.
...
3 - Terceira Clausura.
3.1 - Terceiro paragrafo da Terceira clausura.
3.2 - STerceiro paragrafo da Terceira clausura.
...
/([0-9.]+)s-/g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);