package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9.]+)\s\-`)
var str = `1 - Primeira Clausura.
1.1 - Primeiro paragrafo.
1.2 - Segundo Paragrafo
...ddd
2 - Segunda Clausura.
2.1 - Primeiro paragrafo da segunda clausura.
2.2 - Segundo paragrafo da segunda clausura.
...
3 - Terceira Clausura.
3.1 - Terceiro paragrafo da Terceira clausura.
3.2 - STerceiro paragrafo da Terceira clausura.
...
/([0-9.]+)s-/g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}