import re
regex = re.compile(r"([0-9.]+)\s\-")
test_str = ("1 - Primeira Clausura.\n"
"1.1 - Primeiro paragrafo.\n"
"1.2 - Segundo Paragrafo\n"
"...ddd\n\n"
"2 - Segunda Clausura.\n"
"2.1 - Primeiro paragrafo da segunda clausura.\n"
"2.2 - Segundo paragrafo da segunda clausura.\n"
"...\n\n"
"3 - Terceira Clausura.\n"
"3.1 - Terceiro paragrafo da Terceira clausura.\n"
"3.2 - STerceiro paragrafo da Terceira clausura.\n"
"...\n"
"/([0-9.]+)s-/g")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")