import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9.]+)\\s\\-";
final String string = "1 - Primeira Clausura.\n"
+ "1.1 - Primeiro paragrafo.\n"
+ "1.2 - Segundo Paragrafo\n"
+ "...ddd\n\n"
+ "2 - Segunda Clausura.\n"
+ "2.1 - Primeiro paragrafo da segunda clausura.\n"
+ "2.2 - Segundo paragrafo da segunda clausura.\n"
+ "...\n\n"
+ "3 - Terceira Clausura.\n"
+ "3.1 - Terceiro paragrafo da Terceira clausura.\n"
+ "3.2 - STerceiro paragrafo da Terceira clausura.\n"
+ "...\n"
+ "/([0-9.]+)s-/g";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}