using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9.]+)\s\-";
string input = @"1 - Primeira Clausura.
1.1 - Primeiro paragrafo.
1.2 - Segundo Paragrafo
...ddd
2 - Segunda Clausura.
2.1 - Primeiro paragrafo da segunda clausura.
2.2 - Segundo paragrafo da segunda clausura.
...
3 - Terceira Clausura.
3.1 - Terceiro paragrafo da Terceira clausura.
3.2 - STerceiro paragrafo da Terceira clausura.
...
/([0-9.]+)s-/g";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}