const regex = /(.*?)\/([\d]{5})(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)\\\/([\\d]{5})(.*)', '')
const str = `https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en
`;
const subst = `$1/123456$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);