$re = '/(.*?)\/([\d]{5})(.*)/';
$str = 'https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en
';
$subst = "$1/123456$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;