import Foundation
let pattern = #"(.*?)\/([\d]{5})(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/123456$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}