// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*?)\/([\d]{5})(.*)").unwrap();
let string = "https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en
";
let substitution = "$1/123456$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}