# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)\/([\d]{5})(.*)"
test_str = ("https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en\n")
subst = "$1/123456$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.