use strict;
my $str = 'https://aabc.maternityneighborhood.com/limesurvey/index.php/survey/index/sid/682189/loadall/reload/scid/36636/loadname/cdahlhausen/loadpass/test/lang/en
';
my $regex = qr/(.*?)\/([\d]{5})(.*)/p;
my $subst = '$1/123456$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";