#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>"
Local $sString = "<html lang="{{var=doc-lang}}">" & @CRLF & _
"<head>" & @CRLF & _
"<title>{{var=doc-title}}</div>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<div class="container">" & @CRLF & _
" <div class="row" {{while products}}>" & @CRLF & _
" {{var name}}" & @CRLF & _
" {{var sku}}" & @CRLF & _
" {{var barcode}}" & @CRLF & _
" </div {{while end}}>" & @CRLF & _
"</div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")