re = /\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>/i
str = '<html lang="{{var=doc-lang}}">
<head>
<title>{{var=doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end