$re = '/\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>/i';
$str = '<html lang="{{var=doc-lang}}">
<head>
<title>{{var=doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);