// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>").unwrap();
let string = "<html lang=\"{{var=doc-lang}}\">
<head>
<title>{{var=doc-title}}</div>
</head>
<body>
<div class=\"container\">
<div class=\"row\" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}