const regex = /\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<((.*)\\{\\{while\\s+(.*)\\}\\}(.*)\\{\\{while\\s+end\\}\\})\\>', 'gi')
const str = `<html lang="{{var=doc-lang}}">
<head>
<title>{{var=doc-title}}</div>
</head>
<body>
<div class="container">
<div class="row" {{while products}}>
{{var name}}
{{var sku}}
{{var barcode}}
</div {{while end}}>
</div>
</body>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}