import re
regex = re.compile(r"\<((.*)\{\{while\s+(.*)\}\}(.*)\{\{while\s+end\}\})\>", flags=re.IGNORECASE)
test_str = ("<html lang=\"{{var=doc-lang}}\">\n"
"<head>\n"
"<title>{{var=doc-title}}</div>\n"
"</head>\n"
"<body>\n"
"<div class=\"container\">\n"
" <div class=\"row\" {{while products}}>\n"
" {{var name}}\n"
" {{var sku}}\n"
" {{var barcode}}\n"
" </div {{while end}}>\n"
"</div>\n"
"</body>\n"
"</html>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")