#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\-*() ,<>'\":/=]+)@([\p{L}\-\.\d]+)((\.(\p{L}){2,63})+)$"
Local $sString = "kürem"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")