using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\-*() ,<>'\"":/=]+)@([\p{L}\-\.\d]+)((\.(\p{L}){2,63})+)$";
string input = @"kürem";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}