$re = '/^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\\\-*() ,<>\'\":/=]+)@([\p{L}\-\.\d]+)((\.(\p{L}){2,63})+)$/i';
$str = 'kürem';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);