re = /^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\-*() ,<>'\":\/=]+)@([\p{L}\-\.\d]+)((\.(\p{L}){2,63})+)$/i
str = 'kürem'
# Print the match result
str.match(re) do |match|
puts match.to_s
end