package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\-*() ,<>'\":/=]+)@([\p{L}\-\.\d]+)((\.(\p{L}){2,63})+)$`)
var str = `kürem`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}