const regex = new RegExp('^([^a-zA-Z0-9ğüşöçıİĞÜŞÖÇ!?.\\\\-*() ,<>\\'\\":/=]+)@([\\p{L}\\-\\.\\d]+)((\\.(\\p{L}){2,63})+)$', 'i')
const str = `kürem`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}