using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$";
string input = @"02/2413
11/2011
01/2015
02/2013
12/2014
02/2013
01-2013
02/2013
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}