package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$`)
var str = `02/2413
11/2011
01/2015
02/2013
12/2014
02/2013
01-2013
02/2013
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}