import re
regex = re.compile(r"^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$", flags=re.MULTILINE)
test_str = ("02/2413\n"
"11/2011\n"
"01/2015\n"
"02/2013\n"
"12/2014\n"
"02/2013\n"
"01-2013\n"
"02/2013\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")