const regex = /^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|1[0-2])(\\\/|-)([0-9]{4})$', 'gm')
const str = `02/2413
11/2011
01/2015
02/2013
12/2014
02/2013
01-2013
02/2013
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}