#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?us)<div class="row container-items">(.+?)\n\n<\/div>"
Local $sString = "<div class="row container-items">" & @CRLF & _
"" & @CRLF & _
"<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">" & @CRLF & _
" <div class="panel panel-default">" & @CRLF & _
" <div class="panel-body image-panel">" & @CRLF & _
" <a href="/p/{% p_link %}">" & @CRLF & _
" <div class="item_image">" & @CRLF & _
" <img src="/data/sorted/{% image_src %}">" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="panel-footer">" & @CRLF & _
" <div class="panel-heading category_view">" & @CRLF & _
" <div class="text-left">" & @CRLF & _
" <font color="#777">{% item_category %}</font>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="text-right">{% count_view %}</div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--<div class="caption_view">" & @CRLF & _
" {% item_caption %}" & @CRLF & _
" </div> -->" & @CRLF & _
" <a href="/p/{% p_link %}">посмотреть...</a>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="col-xs-4 col-sm-4 col-md-4 col-lg-4 col-center-block">" & @CRLF & _
" <div class="panel panel-default">" & @CRLF & _
" <div class="panel-body image-panel">" & @CRLF & _
" <a href="/p/{% p_link %}">" & @CRLF & _
" <div class="item_image">" & @CRLF & _
" <img src="/data/sorted/{% image_src %}">" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="panel-footer">" & @CRLF & _
" <div class="panel-heading category_view">" & @CRLF & _
" <div class="text-left">" & @CRLF & _
" <font color="#777">{% item_category %}</font>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="text-right">{% count_view %}</div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--<div class="caption_view">" & @CRLF & _
" {% item_caption %}" & @CRLF & _
" </div> -->" & @CRLF & _
" <a href="/p/{% p_link %}">посмотреть...</a>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")